Unable to debug in eclipse

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to debug in eclipse

mridula
Dear Reader,

I downloaded the SSP and uPortal projects from GIT and was able to build and deploy them in tomcat.

I would like to run SSP platform in eclipse so that I can debug the code to understand it better. I have opened the project in eclipse, but when I run it on the server (tomcat) I keep getting the error ClassNotFoundException: javax.portlet.PortletRequest.

I am new to uPortal, so I may have missed something. Could you please guide me through this?

Thanks for your assistance.

Mridula.
---
You are currently subscribed to [hidden email] as: [hidden email]
To unsubscribe, change settings or access archives, see http://www.ja-sig.org/wiki/display/JSG/ssp-dev
Reply | Threaded
Open this post in threaded view
|

Re: Unable to debug in eclipse

dmccallum
Administrator
Do you get the same error when starting Tomcat from the command line?

Most likely you're missing 'shared.loader' configuration in <tomcat>/conf/catalina.properties. See the Tomcat subsection under Software Prerequisites in the dev install instructions. [1]

If that config has been set but you're still getting the error, look in <tomcat>/shared/lib to see if you have a portlet-api.jar (the ant build should be putting it there) and that it's readable to the user as whom you run Tomcat.

- Dan


On Oct 6, 2014, at 4:18 AM, Mridula <[hidden email]> wrote:

Dear Reader,

I downloaded the SSP and uPortal projects from GIT and was able to build and deploy them in tomcat.

I would like to run SSP platform in eclipse so that I can debug the code to understand it better. I have opened the project in eclipse, but when I run it on the server (tomcat) I keep getting the error ClassNotFoundException: javax.portlet.PortletRequest.

I am new to uPortal, so I may have missed something. Could you please guide me through this?

Thanks for your assistance.

Mridula.
---
You are currently subscribed to [hidden email] as: [hidden email]
To unsubscribe, change settings or access archives, see http://www.ja-sig.org/wiki/display/JSG/ssp-dev

---
You are currently subscribed to [hidden email] as: [hidden email]
To unsubscribe, change settings or access archives, see http://www.ja-sig.org/wiki/display/JSG/ssp-dev

Reply | Threaded
Open this post in threaded view
|

Re: Unable to debug in eclipse

dmccallum
Administrator
In reply to this post by mridula
Does it work when you start SSP from the command line? If so, try enabling debug mode via command line opts and connect Eclipse to the already-running Tomcat JVM [1].

- Dan

[1] - http://wiki.apache.org/tomcat/FAQ/Developing#Q1

On Oct 6, 2014, at 10:32 PM, Mridula <[hidden email]> wrote:

Dear Daniel,

Thank you for your reply.

However, I have correctly configured shared.loader in catalina.properties:

shared.loader=${catalina.home}/shared/classes,${catalina.home}/shared/*.jar,/usr/share/tomcat6/shared/lib/*.jar,{catalina.home}/shared/lib/*.jar

And, the jars are also present in the shared/lib folder:

mridula@mridula-desktop:~$ ls -l /usr/share/tomcat6/shared/lib/
total 192
-rw-rw-r-- 1 mridula mridula 15048 Sep 29 17:05 ccpp.jar
-rw-rw-r-- 1 mridula mridula  8163 Sep 29 17:05 person-directory-api.jar
-rw-rw-r-- 1 mridula mridula 10938 Sep 29 17:05 platform-java-api.jar
-rw-rw-r-- 1 mridula mridula 39572 Sep 29 17:05 pluto-container-api.jar
-rw-rw-r-- 1 mridula mridula 23426 Sep 29 17:05 pluto-container-driver-api.jar
-rw-rw-r-- 1 mridula mridula 43164 Sep 29 17:05 pluto-taglib.jar
-rw-rw-r-- 1 mridula mridula 48049 Sep 29 17:05 portlet-api.jar


And I have also attached the console log when debugging the SSP project in eclipse.

Could you please let me know if I am doing something wrong?

Regards,
Mridula.
---
You are currently subscribed to [hidden email] as: [hidden email]
To unsubscribe, change settings or access archives, see http://www.ja-sig.org/wiki/display/JSG/ssp-dev

---
You are currently subscribed to [hidden email] as: [hidden email]
To unsubscribe, change settings or access archives, see http://www.ja-sig.org/wiki/display/JSG/ssp-dev




ssp_tomcat_start_log.txt (8K) Download Attachment