Re: initportal issues with hibernate on uportal 4.3.1

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: initportal issues with hibernate on uportal 4.3.1

Benito J. Gonzalez-2
Hi Stephen,

This looks like a dependency issue with the plugin. Trying adding those dependencies under the plugin definition for NewsReader's POM.

Best,
--bjagg


From: "Stephen" <[hidden email]>
To: "uPortal Community" <[hidden email]>
Sent: Thursday, July 11, 2019 9:27:03 AM
Subject: [uportal-user] initportal issues with hibernate on uportal 4.3.1

Hi all
Has anyone seen this issue pop up during init?

     [exec] [INFO] ------------------------------------------------------------------------
     
[exec] [INFO]
     
[exec] [INFO] >>> hibernate3-maven-plugin:2.2:hbm2ddl (default) > process-resources @ NewsReaderPortlet >>>
     
[exec] [INFO]
     
[exec] [INFO] --- maven-enforcer-plugin:1.2:enforce (enforce-maven) @ NewsReaderPortlet ---
     
[exec] [INFO]
     
[exec] [INFO] --- maven-enforcer-plugin:1.2:enforce (enforce-versions) @ NewsReaderPortlet ---
     
[exec] [INFO]
     
[exec] [INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ NewsReaderPortlet ---
     
[exec] [INFO] Using 'UTF-8' encoding to copy filtered resources.
     
[exec] [INFO] Copying 0 resource
     
[exec] [INFO] Copying 2 resources
     
[exec] [INFO]
     
[exec] [INFO] <<< hibernate3-maven-plugin:2.2:hbm2ddl (default) < process-resources @ NewsReaderPortlet <<<
     
[exec] [INFO]
     
[exec] [INFO] --- hibernate3-maven-plugin:2.2:hbm2ddl (default) @ NewsReaderPortlet ---
     
[exec] [WARNING] The POM for javax.script:script-api:jar:1.0 is missing, no dependency information available
     
[exec] [WARNING] The POM for javax.script:groovy-engine:jar:jdk14:1.1 is missing, no dependency information available
     
[exec] [WARNING] The POM for javax.script:js-engine:jar:jdk14:1.1 is missing, no dependency information available
     
[exec] [INFO] ------------------------------------------------------------------------
     
[exec] [INFO] Reactor Summary:
     
[exec] [INFO]
     
[exec] [INFO] uPortal Portlets ................................... SUCCESS [  0.044 s]
     
[exec] [INFO] Announcements Portlet .............................. SUCCESS [ 11.018 s]
     
[exec] [INFO] Basic LTI Portlet .................................. SUCCESS [  0.002 s]
     
[exec] [INFO] Bookmarks Portlet .................................. SUCCESS [  0.001 s]
     
[exec] [INFO] Email Preview Portlet .............................. SUCCESS [  0.001 s]
     
[exec] [INFO] Functional Tests Portlet ........................... SUCCESS [  0.002 s]
     
[exec] [INFO] Jasig Widget Portlets .............................. SUCCESS [  0.000 s]
     
[exec] [INFO] Pluto Test Suite Portlet ........................... SUCCESS [  0.001 s]
     
[exec] [INFO] News Reader Portlet ................................ FAILURE [  1.077 s]
     
[exec] [INFO] Jasig Notification Portlet ......................... SKIPPED
     
[exec] [INFO] Sakai Connector Portlet ............................ SKIPPED
     
[exec] [INFO] Simple Content Portlet ............................. SKIPPED
     
[exec] [INFO] Weather Portlet .................................... SKIPPED
     
[exec] [INFO] Web Proxy Portlet .................................. SKIPPED
     
[exec] [INFO] ------------------------------------------------------------------------
     
[exec] [INFO] BUILD FAILURE
     
[exec] [INFO] ------------------------------------------------------------------------
     
[exec] [INFO] Total time: 14.075 s
     
[exec] [INFO] Finished at: 2019-07-11T10:30:57-04:00
     
[exec] [INFO] Final Memory: 27M/258M
     
[exec] [INFO] ------------------------------------------------------------------------
     
[exec] [ERROR] Failed to execute goal org.codehaus.mojo:hibernate3-maven-plugin:2.2:hbm2ddl (default) on project NewsReaderPortlet: Execution default of goal org.codehaus.mojo:hibernate3-maven-plugin:2.2:hbm2ddl failed: Plugin org.codehaus.mojo:hibernate3-maven-plugin:2.2 or one of its dependencies could not be resolved: The following artifacts could not be resolved: javax.script:script-api:jar:1.0, javax.script:groovy-engine:jar:jdk14:1.1, javax.script:js-engine:jar:jdk14:1.1: Failure to find javax.script:script-api:jar:1.0 in https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced -> [Help 1]
     
[exec] [ERROR]
     
[exec] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
     
[exec] [ERROR] Re-run Maven using the -X switch to enable full debug logging.
     
[exec] [ERROR]
     
[exec] [ERROR] For more information about the errors and possible solutions, please read the following articles:
     
[exec] [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
     
[exec] [ERROR]
     
[exec] [ERROR] After correcting the problems, you can resume the build with the command
     
[exec] [ERROR]   mvn <goals> -rf :NewsReaderPortlet
     
[exec] [INFO] cleaning up connection pool: jdbc:mysql://localhost/uPortal

I've tried adding dependencies on the main pom but the issue is still there.

Any help is appreciated.

-S

--
You received this message because you are subscribed to the Google Groups "uPortal Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/a/apereo.org/d/msgid/uportal-user/5b5a4dac-d05a-4762-a8d1-0e4b01f14856%40apereo.org.

--
You received this message because you are subscribed to the Google Groups "uPortal Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/a/apereo.org/d/msgid/uportal-user/289488793.402921.1562869071995.JavaMail.zimbra%40unicon.net.
Reply | Threaded
Open this post in threaded view
|

Re: initportal issues with hibernate on uportal 4.3.1

Stephen
Tried hat with same result. Now, Im not exceedingly familiar with building maven projects so it is entirely possible Im missing stuff. I added the dependencies to the news reader portlet pom as seen below with the dependency blocks taken from where i could find them doing a quick search on mvnrepository.com

do i need to add a repo for this to work?

-S

            <plugin>
                <groupId>org.codehaus.mojo</groupId>
                <artifactId>hibernate3-maven-plugin</artifactId>
                <version>2.2</version>
                <executions>
                    <execution>
                        <phase>db-init</phase>
                        <goals>
                            <goal>hbm2ddl</goal>
                        </goals>
                        <configuration>
                            <componentProperties>
                                <propertyfile>${project.build.directory}/classes/datasource.properties</propertyfile>
                                <drop>true</drop>
                            </componentProperties>
                        </configuration>
                    </execution>
                </executions>
                <dependencies>
                    <dependency>
                        <groupId>org.jasig.portal</groupId>
                        <artifactId>uportal-db</artifactId>
                        <version>${project.version}</version>
                        <type>pom</type>
                        <scope>compile</scope>
                    </dependency>
                    <dependency>
                        <groupId>org.jasig.portlet</groupId>
                        <artifactId>NewsReaderPortlet</artifactId>
                        <version>${NewsReaderPortlet.version}</version>
                        <classifier>classes</classifier>
                        <type>jar</type>
                        <scope>compile</scope>
                    </dependency>
                    <!-- https://mvnrepository.com/artifact/javax.script/script-api -->
                    <dependency>
                            <groupId>javax.script</groupId>
                            <artifactId>script-api</artifactId>
                            <version>1.0</version>
                    </dependency>
                    <!-- https://mvnrepository.com/artifact/javax.script/groovy-engine -->
                    <dependency>
                            <groupId>javax.script</groupId>
                            <artifactId>groovy-engine</artifactId>
                            <version>1.1</version>
                    </dependency>
                    <!-- https://mvnrepository.com/artifact/javax.script/js-engine -->
                    <dependency>
                            <groupId>javax.script</groupId>
                            <artifactId>js-engine</artifactId>
                            <version>1.1</version>
                    </dependency>
                </dependencies>
            </plugin>


On Thursday, July 11, 2019 at 2:17:54 PM UTC-4, bgonzalez wrote:
Hi Stephen,

This looks like a dependency issue with the plugin. Trying adding those dependencies under the plugin definition for NewsReader's POM.

Best,
--bjagg


From: "Stephen" <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="WM_IdhVXBwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dark7soul...@...>
To: "uPortal Community" <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="WM_IdhVXBwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">uporta...@...>
Sent: Thursday, July 11, 2019 9:27:03 AM
Subject: [uportal-user] initportal issues with hibernate on uportal 4.3.1

Hi all
Has anyone seen this issue pop up during init?

     [exec] [INFO] ------------------------------------------------------------------------
     
[exec] [INFO]
     
[exec] [INFO] >>> hibernate3-maven-plugin:2.2:hbm2ddl (default) > process-resources @ NewsReaderPortlet >>>
     
[exec] [INFO]
     
[exec] [INFO] --- maven-enforcer-plugin:1.2:enforce (enforce-maven) @ NewsReaderPortlet ---
     
[exec] [INFO]
     
[exec] [INFO] --- maven-enforcer-plugin:1.2:enforce (enforce-versions) @ NewsReaderPortlet ---
     
[exec] [INFO]
     
[exec] [INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ NewsReaderPortlet ---
     
[exec] [INFO] Using 'UTF-8' encoding to copy filtered resources.
     
[exec] [INFO] Copying 0 resource
     
[exec] [INFO] Copying 2 resources
     
[exec] [INFO]
     
[exec] [INFO] <<< hibernate3-maven-plugin:2.2:hbm2ddl (default) < process-resources @ NewsReaderPortlet <<<
     
[exec] [INFO]
     
[exec] [INFO] --- hibernate3-maven-plugin:2.2:hbm2ddl (default) @ NewsReaderPortlet ---
     
[exec] [WARNING] The POM for javax.script:script-api:jar:1.0 is missing, no dependency information available
     
[exec] [WARNING] The POM for javax.script:groovy-engine:jar:jdk14:1.1 is missing, no dependency information available
     
[exec] [WARNING] The POM for javax.script:js-engine:jar:jdk14:1.1 is missing, no dependency information available
     
[exec] [INFO] ------------------------------------------------------------------------
     
[exec] [INFO] Reactor Summary:
     
[exec] [INFO]
     
[exec] [INFO] uPortal Portlets ................................... SUCCESS [  0.044 s]
     
[exec] [INFO] Announcements Portlet .............................. SUCCESS [ 11.018 s]
     
[exec] [INFO] Basic LTI Portlet .................................. SUCCESS [  0.002 s]
     
[exec] [INFO] Bookmarks Portlet .................................. SUCCESS [  0.001 s]
     
[exec] [INFO] Email Preview Portlet .............................. SUCCESS [  0.001 s]
     
[exec] [INFO] Functional Tests Portlet ........................... SUCCESS [  0.002 s]
     
[exec] [INFO] Jasig Widget Portlets .............................. SUCCESS [  0.000 s]
     
[exec] [INFO] Pluto Test Suite Portlet ........................... SUCCESS [  0.001 s]
     
[exec] [INFO] News Reader Portlet ................................ FAILURE [  1.077 s]
     
[exec] [INFO] Jasig Notification Portlet ......................... SKIPPED
     
[exec] [INFO] Sakai Connector Portlet ............................ SKIPPED
     
[exec] [INFO] Simple Content Portlet ............................. SKIPPED
     
[exec] [INFO] Weather Portlet .................................... SKIPPED
     
[exec] [INFO] Web Proxy Portlet .................................. SKIPPED
     
[exec] [INFO] ------------------------------------------------------------------------
     
[exec] [INFO] BUILD FAILURE
     
[exec] [INFO] ------------------------------------------------------------------------
     
[exec] [INFO] Total time: 14.075 s
     
[exec] [INFO] Finished at: 2019-07-11T10:30:57-04:00
     
[exec] [INFO] Final Memory: 27M/258M
     
[exec] [INFO] ------------------------------------------------------------------------
     
[exec] [ERROR] Failed to execute goal org.codehaus.mojo:hibernate3-maven-plugin:2.2:hbm2ddl (default) on project NewsReaderPortlet: Execution default of goal org.codehaus.mojo:hibernate3-maven-plugin:2.2:hbm2ddl failed: Plugin org.codehaus.mojo:hibernate3-maven-plugin:2.2 or one of its dependencies could not be resolved: The following artifacts could not be resolved: javax.script:script-api:jar:1.0, javax.script:groovy-engine:jar:jdk14:1.1, javax.script:js-engine:jar:jdk14:1.1: Failure to find javax.script:script-api:jar:1.0 in https://<a href="http://repo.maven.apache.org/maven2" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Frepo.maven.apache.org%2Fmaven2\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGf_pyATeVihV-Qi2KYxyxHYNgHAg&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Frepo.maven.apache.org%2Fmaven2\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGf_pyATeVihV-Qi2KYxyxHYNgHAg&#39;;return true;">repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced -> [Help 1]
     
[exec] [ERROR]
     
[exec] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
     
[exec] [ERROR] Re-run Maven using the -X switch to enable full debug logging.
     
[exec] [ERROR]
     
[exec] [ERROR] For more information about the errors and possible solutions, please read the following articles:
     
[exec] [ERROR] [Help 1] http://<a href="http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fcwiki.apache.org%2Fconfluence%2Fdisplay%2FMAVEN%2FPluginResolutionException\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGwJqraX3LGkIEMl8xO1AbLyLoYiA&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fcwiki.apache.org%2Fconfluence%2Fdisplay%2FMAVEN%2FPluginResolutionException\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGwJqraX3LGkIEMl8xO1AbLyLoYiA&#39;;return true;">cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
     
[exec] [ERROR]
     
[exec] [ERROR] After correcting the problems, you can resume the build with the command
     
[exec] [ERROR]   mvn <goals> -rf :NewsReaderPortlet
     
[exec] [INFO] cleaning up connection pool: jdbc:mysql://localhost/uPortal

I've tried adding dependencies on the main pom but the issue is still there.

Any help is appreciated.

-S

--
You received this message because you are subscribed to the Google Groups "uPortal Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="WM_IdhVXBwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">uporta...@apereo.org.
To view this discussion on the web visit <a href="https://groups.google.com/a/apereo.org/d/msgid/uportal-user/5b5a4dac-d05a-4762-a8d1-0e4b01f14856%40apereo.org?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/a/apereo.org/d/msgid/uportal-user/5b5a4dac-d05a-4762-a8d1-0e4b01f14856%40apereo.org?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/a/apereo.org/d/msgid/uportal-user/5b5a4dac-d05a-4762-a8d1-0e4b01f14856%40apereo.org?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/a/apereo.org/d/msgid/uportal-user/5b5a4dac-d05a-4762-a8d1-0e4b01f14856%40apereo.org.

--
You received this message because you are subscribed to the Google Groups "uPortal Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/a/apereo.org/d/msgid/uportal-user/597b8c01-0dab-42f7-94da-c8a855cea537%40apereo.org.
Reply | Threaded
Open this post in threaded view
|

Re: initportal issues with hibernate on uportal 4.3.1

Benito J. Gonzalez-2
Yep, that was my suggestion.

Maybe upgrade the plugin to 3.0 and see if results change?

--bjagg


From: "Stephen" <[hidden email]>
To: "uPortal Community" <[hidden email]>
Cc: "Stephen" <[hidden email]>
Sent: Thursday, July 11, 2019 11:44:10 AM
Subject: Re: [uportal-user] initportal issues with hibernate on uportal 4.3.1

Tried hat with same result. Now, Im not exceedingly familiar with building maven projects so it is entirely possible Im missing stuff. I added the dependencies to the news reader portlet pom as seen below with the dependency blocks taken from where i could find them doing a quick search on mvnrepository.com
do i need to add a repo for this to work?

-S

            <plugin>
                <groupId>org.codehaus.mojo</groupId>
                <artifactId>hibernate3-maven-plugin</artifactId>
                <version>2.2</version>
                <executions>
                    <execution>
                        <phase>db-init</phase>
                        <goals>
                            <goal>hbm2ddl</goal>
                        </goals>
                        <configuration>
                            <componentProperties>
                                <propertyfile>${project.build.directory}/classes/datasource.properties</propertyfile>
                                <drop>true</drop>
                            </componentProperties>
                        </configuration>
                    </execution>
                </executions>
                <dependencies>
                    <dependency>
                        <groupId>org.jasig.portal</groupId>
                        <artifactId>uportal-db</artifactId>
                        <version>${project.version}</version>
                        <type>pom</type>
                        <scope>compile</scope>
                    </dependency>
                    <dependency>
                        <groupId>org.jasig.portlet</groupId>
                        <artifactId>NewsReaderPortlet</artifactId>
                        <version>${NewsReaderPortlet.version}</version>
                        <classifier>classes</classifier>
                        <type>jar</type>
                        <scope>compile</scope>
                    </dependency>
                    <!-- https://mvnrepository.com/artifact/javax.script/script-api -->
                    <dependency>
                            <groupId>javax.script</groupId>
                            <artifactId>script-api</artifactId>
                            <version>1.0</version>
                    </dependency>
                    <!-- https://mvnrepository.com/artifact/javax.script/groovy-engine -->
                    <dependency>
                            <groupId>javax.script</groupId>
                            <artifactId>groovy-engine</artifactId>
                            <version>1.1</version>
                    </dependency>
                    <!-- https://mvnrepository.com/artifact/javax.script/js-engine -->
                    <dependency>
                            <groupId>javax.script</groupId>
                            <artifactId>js-engine</artifactId>
                            <version>1.1</version>
                    </dependency>
                </dependencies>
            </plugin>


On Thursday, July 11, 2019 at 2:17:54 PM UTC-4, bgonzalez wrote:
Hi Stephen,

This looks like a dependency issue with the plugin. Trying adding those dependencies under the plugin definition for NewsReader's POM.

Best,
--bjagg


From: "Stephen" <<a href="JAVASCRIPT-BLOCKED:" target="_blank" rel="nofollow">dark7soul...@...>
To: "uPortal Community" <<a href="JAVASCRIPT-BLOCKED:" target="_blank" rel="nofollow">uporta...@...>
Sent: Thursday, July 11, 2019 9:27:03 AM
Subject: [uportal-user] initportal issues with hibernate on uportal 4.3.1

Hi all
Has anyone seen this issue pop up during init?

     [exec] [INFO] ------------------------------------------------------------------------
     
[exec] [INFO]
     
[exec] [INFO] >>> hibernate3-maven-plugin:2.2:hbm2ddl (default) > process-resources @ NewsReaderPortlet >>>
     
[exec] [INFO]
     
[exec] [INFO] --- maven-enforcer-plugin:1.2:enforce (enforce-maven) @ NewsReaderPortlet ---
     
[exec] [INFO]
     
[exec] [INFO] --- maven-enforcer-plugin:1.2:enforce (enforce-versions) @ NewsReaderPortlet ---
     
[exec] [INFO]
     
[exec] [INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ NewsReaderPortlet ---
     
[exec] [INFO] Using 'UTF-8' encoding to copy filtered resources.
     
[exec] [INFO] Copying 0 resource
     
[exec] [INFO] Copying 2 resources
     
[exec] [INFO]
     
[exec] [INFO] <<< hibernate3-maven-plugin:2.2:hbm2ddl (default) < process-resources @ NewsReaderPortlet <<<
     
[exec] [INFO]
     
[exec] [INFO] --- hibernate3-maven-plugin:2.2:hbm2ddl (default) @ NewsReaderPortlet ---
     
[exec] [WARNING] The POM for javax.script:script-api:jar:1.0 is missing, no dependency information available
     
[exec] [WARNING] The POM for javax.script:groovy-engine:jar:jdk14:1.1 is missing, no dependency information available
     
[exec] [WARNING] The POM for javax.script:js-engine:jar:jdk14:1.1 is missing, no dependency information available
     
[exec] [INFO] ------------------------------------------------------------------------
     
[exec] [INFO] Reactor Summary:
     
[exec] [INFO]
     
[exec] [INFO] uPortal Portlets ................................... SUCCESS [  0.044 s]
     
[exec] [INFO] Announcements Portlet .............................. SUCCESS [ 11.018 s]
     
[exec] [INFO] Basic LTI Portlet .................................. SUCCESS [  0.002 s]
     
[exec] [INFO] Bookmarks Portlet .................................. SUCCESS [  0.001 s]
     
[exec] [INFO] Email Preview Portlet .............................. SUCCESS [  0.001 s]
     
[exec] [INFO] Functional Tests Portlet ........................... SUCCESS [  0.002 s]
     
[exec] [INFO] Jasig Widget Portlets .............................. SUCCESS [  0.000 s]
     
[exec] [INFO] Pluto Test Suite Portlet ........................... SUCCESS [  0.001 s]
     
[exec] [INFO] News Reader Portlet ................................ FAILURE [  1.077 s]
     
[exec] [INFO] Jasig Notification Portlet ......................... SKIPPED
     
[exec] [INFO] Sakai Connector Portlet ............................ SKIPPED
     
[exec] [INFO] Simple Content Portlet ............................. SKIPPED
     
[exec] [INFO] Weather Portlet .................................... SKIPPED
     
[exec] [INFO] Web Proxy Portlet .................................. SKIPPED
     
[exec] [INFO] ------------------------------------------------------------------------
     
[exec] [INFO] BUILD FAILURE
     
[exec] [INFO] ------------------------------------------------------------------------
     
[exec] [INFO] Total time: 14.075 s
     
[exec] [INFO] Finished at: 2019-07-11T10:30:57-04:00
     
[exec] [INFO] Final Memory: 27M/258M
     
[exec] [INFO] ------------------------------------------------------------------------
     
[exec] [ERROR] Failed to execute goal org.codehaus.mojo:hibernate3-maven-plugin:2.2:hbm2ddl (default) on project NewsReaderPortlet: Execution default of goal org.codehaus.mojo:hibernate3-maven-plugin:2.2:hbm2ddl failed: Plugin org.codehaus.mojo:hibernate3-maven-plugin:2.2 or one of its dependencies could not be resolved: The following artifacts could not be resolved: javax.script:script-api:jar:1.0, javax.script:groovy-engine:jar:jdk14:1.1, javax.script:js-engine:jar:jdk14:1.1: Failure to find javax.script:script-api:jar:1.0 in https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced -> [Help 1]
     
[exec] [ERROR]
     
[exec] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
     
[exec] [ERROR] Re-run Maven using the -X switch to enable full debug logging.
     
[exec] [ERROR]
     
[exec] [ERROR] For more information about the errors and possible solutions, please read the following articles:
     
[exec] [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
     
[exec] [ERROR]
     
[exec] [ERROR] After correcting the problems, you can resume the build with the command
     
[exec] [ERROR]   mvn <goals> -rf :NewsReaderPortlet
     
[exec] [INFO] cleaning up connection pool: jdbc:mysql://localhost/uPortal

I've tried adding dependencies on the main pom but the issue is still there.

Any help is appreciated.

-S

--
You received this message because you are subscribed to the Google Groups "uPortal Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="JAVASCRIPT-BLOCKED:" target="_blank" rel="nofollow">uporta...@....
To view this discussion on the web visit https://groups.google.com/a/apereo.org/d/msgid/uportal-user/5b5a4dac-d05a-4762-a8d1-0e4b01f14856%40apereo.org.

--
You received this message because you are subscribed to the Google Groups "uPortal Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/a/apereo.org/d/msgid/uportal-user/597b8c01-0dab-42f7-94da-c8a855cea537%40apereo.org.

--
You received this message because you are subscribed to the Google Groups "uPortal Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/a/apereo.org/d/msgid/uportal-user/305546160.408829.1562872363134.JavaMail.zimbra%40unicon.net.