Hello sir, Help me Am having a problem with the shared/lib folder

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Hello sir, Help me Am having a problem with the shared/lib folder

docaustyne
This is my log

[artifact:mvn] [INFO] Building war: C:\portal\uPortal-4.0.2\uportal-portlets-ove
rlay\SimpleContentPortlet\target\SimpleContentPortlet.war
[artifact:mvn] [WARNING] Warning: selected war files include a WEB-INF/web.xml w
hich will be ignored
[artifact:mvn] (webxml attribute is missing from war task, or ignoreWebxml attri
bute is specified as 'true')
[artifact:mvn] [INFO] Packaging classes
[artifact:mvn] [INFO] Building jar: C:\portal\uPortal-4.0.2\uportal-portlets-ove
rlay\SimpleContentPortlet\target\SimpleContentPortlet-classes.jar
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-site-plugin:3.1.r1174614:attach-descriptor (atta
ch-descriptor) @ SimpleContentPortlet ---
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-pluto-plugin:2.1.0-M2:assemble (default) @ Simpl
eContentPortlet ---
[artifact:mvn] [INFO] Assembling archive file C:\portal\uPortal-4.0.2\uportal-po
rtlets-overlay\SimpleContentPortlet\target\SimpleContentPortlet.war to directory
 C:\portal\uPortal-4.0.2\uportal-portlets-overlay\SimpleContentPortlet\target
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-install-plugin:2.3.1:install (default-install) @
 SimpleContentPortlet ---
[artifact:mvn] [INFO] Installing C:\portal\uPortal-4.0.2\uportal-portlets-overla
y\SimpleContentPortlet\target\SimpleContentPortlet.war to C:\Users\Ugi(Jnr)\.m2\
repository\org\jasig\portal\portlets-overlay\SimpleContentPortlet\4.0.2\SimpleCo
ntentPortlet-4.0.2.war
[artifact:mvn] [INFO] Installing C:\portal\uPortal-4.0.2\uportal-portlets-overla
y\SimpleContentPortlet\pom.xml to C:\Users\Ugi(Jnr)\.m2\repository\org\jasig\por
tal\portlets-overlay\SimpleContentPortlet\4.0.2\SimpleContentPortlet-4.0.2.pom
[artifact:mvn] [INFO] Installing C:\portal\uPortal-4.0.2\uportal-portlets-overla
y\SimpleContentPortlet\target\SimpleContentPortlet-classes.jar to C:\Users\Ugi(J
nr)\.m2\repository\org\jasig\portal\portlets-overlay\SimpleContentPortlet\4.0.2\
SimpleContentPortlet-4.0.2-classes.jar
[artifact:mvn] [INFO]

[artifact:mvn] [INFO] ----------------------------------------------------------
--------------
[artifact:mvn] [INFO] Building Weather Portlet 4.0.2
[artifact:mvn] [INFO] ----------------------------------------------------------
--------------
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-enforcer-plugin:1.0:enforce (enforce-maven) @ We
atherPortlet ---
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-enforcer-plugin:1.0:enforce (enforce-versions) @
 WeatherPortlet ---
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-resources-plugin:2.5:resources (default-resource
s) @ WeatherPortlet ---
[artifact:mvn] [debug] execute contextualize
[artifact:mvn] [INFO] Using 'UTF-8' encoding to copy filtered resources.
[artifact:mvn] [INFO] skip non existing resourceDirectory C:\portal\uPortal-4.0.
2\uportal-portlets-overlay\WeatherPortlet\src\main\resources
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-compiler-plugin:2.3.2:compile (default-compile)
@ WeatherPortlet ---
[artifact:mvn] [INFO] No sources to compile
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-resources-plugin:2.5:testResources (default-test
Resources) @ WeatherPortlet ---
[artifact:mvn] [debug] execute contextualize
[artifact:mvn] [INFO] Using 'UTF-8' encoding to copy filtered resources.
[artifact:mvn] [INFO] skip non existing resourceDirectory C:\portal\uPortal-4.0.
2\uportal-portlets-overlay\WeatherPortlet\src\test\resources
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-compiler-plugin:2.3.2:testCompile (default-testC
ompile) @ WeatherPortlet ---
[artifact:mvn] [INFO] No sources to compile
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-surefire-plugin:2.9:test (default-test) @ Weathe
rPortlet ---
[artifact:mvn] [INFO] No tests to run.
[artifact:mvn] [INFO] Surefire report directory: C:\portal\uPortal-4.0.2\uportal
-portlets-overlay\WeatherPortlet\target\surefire-reports
[artifact:mvn]
[artifact:mvn] -------------------------------------------------------
[artifact:mvn]  T E S T S
[artifact:mvn] -------------------------------------------------------
[artifact:mvn]
[artifact:mvn] Results :
[artifact:mvn]
[artifact:mvn] Tests run: 0, Failures: 0, Errors: 0, Skipped: 0
[artifact:mvn]
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-war-plugin:2.1.1:war (default-war) @ WeatherPort
let ---
[artifact:mvn] [INFO] Packaging webapp
[artifact:mvn] [INFO] Assembling webapp [WeatherPortlet] in [C:\portal\uPortal-4
.0.2\uportal-portlets-overlay\WeatherPortlet\target\WeatherPortlet]
[artifact:mvn] [INFO] Processing war project
[artifact:mvn] [INFO] Copying webapp resources [C:\portal\uPortal-4.0.2\uportal-
portlets-overlay\WeatherPortlet\src\main\webapp]
[artifact:mvn] [INFO] Processing overlay [ id org.jasig.portlet:WeatherPortlet]
[artifact:mvn] [INFO] Webapp assembled in [7582 msecs]
[artifact:mvn] [INFO] Building war: C:\portal\uPortal-4.0.2\uportal-portlets-ove
rlay\WeatherPortlet\target\WeatherPortlet.war
[artifact:mvn] [WARNING] Warning: selected war files include a WEB-INF/web.xml w
hich will be ignored
[artifact:mvn] (webxml attribute is missing from war task, or ignoreWebxml attri
bute is specified as 'true')
[artifact:mvn] [INFO] Packaging classes
[artifact:mvn] [INFO] Building jar: C:\portal\uPortal-4.0.2\uportal-portlets-ove
rlay\WeatherPortlet\target\WeatherPortlet-classes.jar
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-site-plugin:3.1.r1174614:attach-descriptor (atta
ch-descriptor) @ WeatherPortlet ---
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-pluto-plugin:2.1.0-M2:assemble (default) @ Weath
erPortlet ---
[artifact:mvn] [INFO] Assembling archive file C:\portal\uPortal-4.0.2\uportal-po
rtlets-overlay\WeatherPortlet\target\WeatherPortlet.war to directory C:\portal\u
Portal-4.0.2\uportal-portlets-overlay\WeatherPortlet\target
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-install-plugin:2.3.1:install (default-install) @
 WeatherPortlet ---
[artifact:mvn] [INFO] Installing C:\portal\uPortal-4.0.2\uportal-portlets-overla
y\WeatherPortlet\target\WeatherPortlet.war to C:\Users\Ugi(Jnr)\.m2\repository\o
rg\jasig\portal\portlets-overlay\WeatherPortlet\4.0.2\WeatherPortlet-4.0.2.war
[artifact:mvn] [INFO] Installing C:\portal\uPortal-4.0.2\uportal-portlets-overla
y\WeatherPortlet\pom.xml to C:\Users\Ugi(Jnr)\.m2\repository\org\jasig\portal\po
rtlets-overlay\WeatherPortlet\4.0.2\WeatherPortlet-4.0.2.pom
[artifact:mvn] [INFO] Installing C:\portal\uPortal-4.0.2\uportal-portlets-overla
y\WeatherPortlet\target\WeatherPortlet-classes.jar to C:\Users\Ugi(Jnr)\.m2\repo
sitory\org\jasig\portal\portlets-overlay\WeatherPortlet\4.0.2\WeatherPortlet-4.0
.2-classes.jar
[artifact:mvn] [INFO]

[artifact:mvn] [INFO] ----------------------------------------------------------
--------------
[artifact:mvn] [INFO] Building Web Proxy Portlet 4.0.2
[artifact:mvn] [INFO] ----------------------------------------------------------
--------------
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-enforcer-plugin:1.0:enforce (enforce-maven) @ We
bProxyPortlet ---
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-enforcer-plugin:1.0:enforce (enforce-versions) @
 WebProxyPortlet ---
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-resources-plugin:2.5:resources (default-resource
s) @ WebProxyPortlet ---
[artifact:mvn] [debug] execute contextualize
[artifact:mvn] [INFO] Using 'UTF-8' encoding to copy filtered resources.
[artifact:mvn] [INFO] Copying 1 resource
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-compiler-plugin:2.3.2:compile (default-compile)
@ WebProxyPortlet ---
[artifact:mvn] [INFO] No sources to compile
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-resources-plugin:2.5:testResources (default-test
Resources) @ WebProxyPortlet ---
[artifact:mvn] [debug] execute contextualize
[artifact:mvn] [INFO] Using 'UTF-8' encoding to copy filtered resources.
[artifact:mvn] [INFO] skip non existing resourceDirectory C:\portal\uPortal-4.0.
2\uportal-portlets-overlay\WebProxyPortlet\src\test\resources
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-compiler-plugin:2.3.2:testCompile (default-testC
ompile) @ WebProxyPortlet ---
[artifact:mvn] [INFO] No sources to compile
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-surefire-plugin:2.9:test (default-test) @ WebPro
xyPortlet ---
[artifact:mvn] [INFO] No tests to run.
[artifact:mvn] [INFO] Surefire report directory: C:\portal\uPortal-4.0.2\uportal
-portlets-overlay\WebProxyPortlet\target\surefire-reports
[artifact:mvn]
[artifact:mvn] -------------------------------------------------------
[artifact:mvn]  T E S T S
[artifact:mvn] -------------------------------------------------------
[artifact:mvn]
[artifact:mvn] Results :
[artifact:mvn]
[artifact:mvn] Tests run: 0, Failures: 0, Errors: 0, Skipped: 0
[artifact:mvn]
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-war-plugin:2.1.1:war (default-war) @ WebProxyPor
tlet ---
[artifact:mvn] [INFO] Packaging webapp
[artifact:mvn] [INFO] Assembling webapp [WebProxyPortlet] in [C:\portal\uPortal-
4.0.2\uportal-portlets-overlay\WebProxyPortlet\target\WebProxyPortlet]
[artifact:mvn] [INFO] Processing war project
[artifact:mvn] [INFO] Copying webapp webResources [C:\portal\uPortal-4.0.2\uport
al-portlets-overlay\WebProxyPortlet/src/main/webapp/WEB-INF] to [C:\portal\uPort
al-4.0.2\uportal-portlets-overlay\WebProxyPortlet\target\WebProxyPortlet]
[artifact:mvn] [INFO] Copying webapp resources [C:\portal\uPortal-4.0.2\uportal-
portlets-overlay\WebProxyPortlet\src\main\webapp]
[artifact:mvn] [INFO] Processing overlay [ id org.jasig.portlet:WebProxyPortlet]

[artifact:mvn] [INFO] Webapp assembled in [7809 msecs]
[artifact:mvn] [INFO] Building war: C:\portal\uPortal-4.0.2\uportal-portlets-ove
rlay\WebProxyPortlet\target\WebProxyPortlet.war
[artifact:mvn] [WARNING] Warning: selected war files include a WEB-INF/web.xml w
hich will be ignored
[artifact:mvn] (webxml attribute is missing from war task, or ignoreWebxml attri
bute is specified as 'true')
[artifact:mvn] [INFO] Packaging classes
[artifact:mvn] [INFO] Building jar: C:\portal\uPortal-4.0.2\uportal-portlets-ove
rlay\WebProxyPortlet\target\WebProxyPortlet-classes.jar
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-site-plugin:3.1.r1174614:attach-descriptor (atta
ch-descriptor) @ WebProxyPortlet ---
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-pluto-plugin:2.1.0-M2:assemble (default) @ WebPr
oxyPortlet ---
[artifact:mvn] [INFO] Assembling archive file C:\portal\uPortal-4.0.2\uportal-po
rtlets-overlay\WebProxyPortlet\target\WebProxyPortlet.war to directory C:\portal
\uPortal-4.0.2\uportal-portlets-overlay\WebProxyPortlet\target
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] --- maven-install-plugin:2.3.1:install (default-install) @
 WebProxyPortlet ---
[artifact:mvn] [INFO] Installing C:\portal\uPortal-4.0.2\uportal-portlets-overla
y\WebProxyPortlet\target\WebProxyPortlet.war to C:\Users\Ugi(Jnr)\.m2\repository
\org\jasig\portal\portlets-overlay\WebProxyPortlet\4.0.2\WebProxyPortlet-4.0.2.w
ar
[artifact:mvn] [INFO] Installing C:\portal\uPortal-4.0.2\uportal-portlets-overla
y\WebProxyPortlet\pom.xml to C:\Users\Ugi(Jnr)\.m2\repository\org\jasig\portal\p
ortlets-overlay\WebProxyPortlet\4.0.2\WebProxyPortlet-4.0.2.pom
[artifact:mvn] [INFO] Installing C:\portal\uPortal-4.0.2\uportal-portlets-overla
y\WebProxyPortlet\target\WebProxyPortlet-classes.jar to C:\Users\Ugi(Jnr)\.m2\re
pository\org\jasig\portal\portlets-overlay\WebProxyPortlet\4.0.2\WebProxyPortlet
-4.0.2-classes.jar
[artifact:mvn] [INFO] ----------------------------------------------------------
--------------
[artifact:mvn] [INFO] Reactor Summary:
[artifact:mvn] [INFO]
[artifact:mvn] [INFO] uPortal Portlets .................................. SUCCES
S [10.219s]
[artifact:mvn] [INFO] Bookmarks Portlet ................................. SUCCES
S [31.453s]
[artifact:mvn] [INFO] CAS Server ........................................ SUCCES
S [28.044s]
[artifact:mvn] [INFO] CAS Proxy Test Portlet ............................ SUCCES
S [10.241s]
[artifact:mvn] [INFO] Email Preview Portlet ............................. SUCCES
S [22.147s]
[artifact:mvn] [INFO] Functional Tests Portlet .......................... SUCCES
S [17.221s]
[artifact:mvn] [INFO] Jasig Widget Portlets ............................. SUCCES
S [22.771s]
[artifact:mvn] [INFO] Pluto Test Suite Portlet .......................... SUCCES
S [5.740s]
[artifact:mvn] [INFO] News Reader Portlet ............................... SUCCES
S [33.430s]
[artifact:mvn] [INFO] Simple Content Portlet ............................ SUCCES
S [44.812s]
[artifact:mvn] [INFO] Weather Portlet ................................... SUCCES
S [17.529s]
[artifact:mvn] [INFO] Web Proxy Portlet ................................. SUCCES
S [20.276s]
[artifact:mvn] [INFO] ----------------------------------------------------------
--------------
[artifact:mvn] [INFO] BUILD SUCCESS
[artifact:mvn] [INFO] ----------------------------------------------------------
--------------
[artifact:mvn] [INFO] Total time: 4:24.996s
[artifact:mvn] [INFO] Finished at: Fri Jan 27 07:43:28 PST 2012
[artifact:mvn] [INFO] Final Memory: 12M/29M
[artifact:mvn] [INFO] ----------------------------------------------------------
--------------
     [echo] Artifact 'C:\portal\uPortal-4.0.2\uportal-ear\target/uPortal.ear' is
 up-to-date
[artifact:install] [INFO] Installing C:\portal\uPortal-4.0.2\uportal-ear\target\
uPortal.ear to C:\Users\Ugi(Jnr)\.m2\repository\org\jasig\portal\uportal-ear\4.0
.2\uportal-ear-4.0.2.ear
     [echo]    extractWars=true
     [echo] removeExisting=true
     [echo]    cleanShared=true

checkForTomcat:

clean-shared:

BUILD FAILED
C:\portal\uPortal-4.0.2\build.xml:139: The following error occurred while execut
ing this line:
C:\portal\uPortal-4.0.2\build.xml:666: The following error occurred while execut
ing this line:
C:\portal\uPortal-4.0.2\build.xml:1421: The following error occurred while execu
ting this line:
C:\portal\uPortal-4.0.2\build.xml:1356: The following error occurred while execu
ting this line:
C:\portal\uPortal-4.0.2\build.xml:1329: The following error occurred while execu
ting this line:
C:\portal\uPortal-4.0.2\build.xml:1332: The following error occurred while execu
ting this line:
C:\portal\uPortal-4.0.2\build.xml:1359: The following error occurred while execu
ting this line:
C:\portal\uPortal-4.0.2\build.xml:1422: The following error occurred while execu
ting this line:
C:\portal\uPortal-4.0.2\build.xml:1390: The following error occurred while execu
ting this line:
C:\portal\uPortal-4.0.2\build.xml:1425: The following error occurred while execu
ting this line:
C:\portal\uPortal-4.0.2\build.xml:674: The following error occurred while execut
ing this line:
C:\portal\uPortal-4.0.2\build.xml:639: Directory C:\portal\apache-tomcat-6.0.33
\shared\lib creation was not successful for an unknown reason

Total time: 5 minutes 1 second

please I need help on this issue, C:\portal\uPortal-4.0.2\build.xml:639: Directory C:\portal\apache-tomcat-6.0.33
\shared\lib creation was not successful for an unknown reason
Loading...