Errors when deploying ssp.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Errors when deploying ssp.

mridula
I am done with all installation steps of SSP but while i am executing "ant -Dmaven.test.skip=true clean initportal" command,i got some exceptions like,

   [java] ERROR [08:50.680] Error occured while unregistering JGroupsCacheRece
iver MBean. null
     [java] javax.management.RuntimeOperationsException: Exception occurred tryi
ng to unregister the MBean
     [java]     at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.unregis
terMBean(DefaultMBeanServerInterceptor.java:359) ~[na:1.7.0_75]
     [java]     at com.sun.jmx.mbeanserver.JmxMBeanServer.unregisterMBean(JmxMBe
anServer.java:546) ~[na:1.7.0_75]
     [java]     at net.sf.ehcache.distribution.jgroups.JGroupsCacheReceiver.disp
ose(JGroupsCacheReceiver.java:94) ~[ehcache-jgroups3replication-1.7.4.jar:na]
     [java]     at net.sf.ehcache.distribution.jgroups.JGroupsCacheManagerPeerPr
ovider.shutdownCachePeer(JGroupsCacheManagerPeerProvider.java:205) [ehcache-jgro
ups3replication-1.7.4.jar:na]
     [java]     at net.sf.ehcache.distribution.jgroups.JGroupsCacheManagerPeerPr
ovider.dispose(JGroupsCacheManagerPeerProvider.java:197) [ehcache-jgroups3replic
ation-1.7.4.jar:na]
     [java]     at net.sf.ehcache.CacheManager.shutdown(CacheManager.java:1430)
[ehcache-core-2.6.0.jar:na]
     [java]     at org.springframework.cache.ehcache.EhCacheManagerFactoryBean.d
estroy(EhCacheManagerFactoryBean.java:165) [spring-context-support-3.2.8.RELEASE
.jar:3.2.8.RELEASE]
     [java]     at org.springframework.beans.factory.support.DisposableBeanAdapt
er.destroy(DisposableBeanAdapter.java:238) [spring-beans-3.2.8.RELEASE.jar:3.2.8
.RELEASE]
     [java]     at org.springframework.beans.factory.support.DefaultSingletonBea
nRegistry.destroyBean(DefaultSingletonBeanRegistry.java:510) [spring-beans-3.2.8
.RELEASE.jar:3.2.8.RELEASE]
     [java]     at org.springframework.beans.factory.support.DefaultSingletonBea
nRegistry.destroySingleton(DefaultSingletonBeanRegistry.java:486) [spring-beans-
3.2.8.RELEASE.jar:3.2.8.RELEASE]
     [java]     at org.springframework.beans.factory.support.DefaultListableBean
Factory.destroySingleton(DefaultListableBeanFactory.java:742) [spring-beans-3.2.
8.RELEASE.jar:3.2.8.RELEASE]
     [java]     at org.springframework.beans.factory.support.DefaultSingletonBea
nRegistry.destroySingletons(DefaultSingletonBeanRegistry.java:455) [spring-beans
-3.2.8.RELEASE.jar:3.2.8.RELEASE]
     [java]     at org.springframework.context.support.AbstractApplicationContex
t.destroyBeans(AbstractApplicationContext.java:1090) [spring-context-3.2.8.RELEA
SE.jar:3.2.8.RELEASE]
     [java]     at org.springframework.context.support.AbstractApplicationContex
t.doClose(AbstractApplicationContext.java:1064) [spring-context-3.2.8.RELEASE.ja
r:3.2.8.RELEASE]
     [java]     at org.springframework.context.support.AbstractApplicationContex
t.close(AbstractApplicationContext.java:1010) [spring-context-3.2.8.RELEASE.jar:
3.2.8.RELEASE]
     [java]     at org.springframework.context.support.AbstractApplicationContex
t.destroy(AbstractApplicationContext.java:998) [spring-context-3.2.8.RELEASE.jar
:3.2.8.RELEASE]
     [java]     at org.jasig.portal.shell.PortalShell.main(PortalShell.java:94)
[ssp-platform-classes.jar:2.7.0-SNAPSHOT]
     [java] Caused by: java.lang.IllegalArgumentException: Object name cannot be
 null
     [java]     at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.unregis
terMBean(DefaultMBeanServerInterceptor.java:357) ~[na:1.7.0_75]
     [java]     ... 16 common frames omitted
     [echo] Finished initializing database
     [echo] Finished initializing uPortal

BUILD SUCCESSFUL
Total time: 7 minutes 6 seconds



Then when I execute the command for deploy i.e. "ant -Dmaven.test.skip=true clean deploy-ear", it gets executed successfully. But after that when I started Tomcat, I got another exceptions like,

   Exception in thread "Timer-1" Exception in thread "Timer-3" Exception in thread
"Timer-2" java.lang.NullPointerException
        at org.springframework.aop.framework.DefaultAdvisorChainFactory.getInte
ceptorsAndDynamicInterceptionAdvice(DefaultAdvisorChainFactory.java:62)
        at org.springframework.aop.framework.AdvisedSupport.getInterceptorsAndD
namicInterceptionAdvice(AdvisedSupport.java:482)
Exception in thread "Timer-4"   at org.springframework.aop.framework.JdkDynamic
opProxy.invoke(JdkDynamicAopProxy.java:190)
        at com.sun.proxy.$Proxy112.register(Unknown Source)
        at org.apache.pluto.container.driver.PortletServlet.attemptRegistration
PortletServlet.java:192)
        at org.apache.pluto.container.driver.PortletServlet$1.run(PortletServle
.java:166)
        at java.util.TimerThread.mainLoop(Timer.java:555)
        at java.util.TimerThread.run(Timer.java:505)
java.lang.NullPointerException
        at org.springframework.aop.framework.DefaultAdvisorChainFactory.getInte
ceptorsAndDynamicInterceptionAdvice(DefaultAdvisorChainFactory.java:62)
        at org.springframework.aop.framework.AdvisedSupport.getInterceptorsAndD
namicInterceptionAdvice(AdvisedSupport.java:482)
        at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynam
cAopProxy.java:190)
        at com.sun.proxy.$Proxy112.register(Unknown Source)
        at org.apache.pluto.container.driver.PortletServlet.attemptRegistration
PortletServlet.java:192)
        at org.apache.pluto.container.driver.PortletServlet$1.run(PortletServle
.java:166)
        at java.util.TimerThread.mainLoop(Timer.java:555)
        at java.util.TimerThread.run(Timer.java:505)
java.lang.NullPointerException
        at org.springframework.aop.framework.DefaultAdvisorChainFactory.getInte
ceptorsAndDynamicInterceptionAdvice(DefaultAdvisorChainFactory.java:62)
        at org.springframework.aop.framework.AdvisedSupport.getInterceptorsAndD
namicInterceptionAdvice(AdvisedSupport.java:482)
        at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynam
cAopProxy.java:190)
        at com.sun.proxy.$Proxy112.register(Unknown Source)
        at org.apache.pluto.container.driver.PortletServlet.attemptRegistration
PortletServlet.java:192)
        at org.apache.pluto.container.driver.PortletServlet$1.run(PortletServle
.java:166)
        at java.util.TimerThread.mainLoop(Timer.java:555)
        at java.util.TimerThread.run(Timer.java:505)
java.lang.NullPointerException
        at org.springframework.aop.framework.DefaultAdvisorChainFactory.getInte
ceptorsAndDynamicInterceptionAdvice(DefaultAdvisorChainFactory.java:62)
        at org.springframework.aop.framework.AdvisedSupport.getInterceptorsAndD
namicInterceptionAdvice(AdvisedSupport.java:482)
        at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynam
cAopProxy.java:190)
        at com.sun.proxy.$Proxy112.register(Unknown Source)
        at org.apache.pluto.container.driver.PortletServlet.attemptRegistration
PortletServlet.java:192)
        at org.apache.pluto.container.driver.PortletServlet$1.run(PortletServle
.java:166)
        at java.util.TimerThread.mainLoop(Timer.java:555)
        at java.util.TimerThread.run(Timer.java:505)
Apr 09, 2015 5:20:36 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory docs
Apr 09, 2015 5:20:36 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory examples
Apr 09, 2015 5:20:36 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory NotificationPortlet
Exception in thread "Timer-5" java.lang.NullPointerException
        at org.springframework.aop.framework.DefaultAdvisorChainFactory.getInte
ceptorsAndDynamicInterceptionAdvice(DefaultAdvisorChainFactory.java:62)
        at org.springframework.aop.framework.AdvisedSupport.getInterceptorsAndD
namicInterceptionAdvice(AdvisedSupport.java:482)
        at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynam
cAopProxy.java:190)
        at com.sun.proxy.$Proxy112.register(Unknown Source)
        at org.apache.pluto.container.driver.PortletServlet.attemptRegistration
PortletServlet.java:192)
        at org.apache.pluto.container.driver.PortletServlet$1.run(PortletServle
.java:166)
        at java.util.TimerThread.mainLoop(Timer.java:555)
        at java.util.TimerThread.run(Timer.java:505)
Apr 09, 2015 5:20:37 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory ResourceServingWebapp
Apr 09, 2015 5:20:37 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory ROOT
Apr 09, 2015 5:20:37 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory SimpleContentPortlet
Exception in thread "Timer-6" java.lang.NullPointerException
        at org.springframework.aop.framework.DefaultAdvisorChainFactory.getInte
ceptorsAndDynamicInterceptionAdvice(DefaultAdvisorChainFactory.java:62)
        at org.springframework.aop.framework.AdvisedSupport.getInterceptorsAndD
namicInterceptionAdvice(AdvisedSupport.java:482)
        at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynam
cAopProxy.java:190)
        at com.sun.proxy.$Proxy112.register(Unknown Source)
        at org.apache.pluto.container.driver.PortletServlet.attemptRegistration
PortletServlet.java:192)
        at org.apache.pluto.container.driver.PortletServlet$1.run(PortletServle
.java:166)
        at java.util.TimerThread.mainLoop(Timer.java:555)
        at java.util.TimerThread.run(Timer.java:505)
Apr 09, 2015 5:20:38 PM org.apache.coyote.http11.Http11AprProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Apr 09, 2015 5:20:38 PM org.apache.coyote.ajp.AjpAprProtocol start
INFO: Starting Coyote AJP/1.3 on ajp-8009
Apr 09, 2015 5:20:38 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 37929 ms

And after that when I point my browser to "http://localhost:8080/ssp-platform" , it gives error-HTTP Status 404.
  Here i am attaching localhost.log and ssp.log files.

I've verified all the installation steps given here,https://wiki.jasig.org/display/SSP/SSP+Developer+Installation+Instructions and everything is in order. I am working on 64 bit Windows7.

So what should i do to solve this problem?
---
You are currently subscribed to [hidden email] as: [hidden email]
To unsubscribe, change settings or access archives, see http://www.ja-sig.org/wiki/display/JSG/ssp-dev

ssp.log (66K) Download Attachment
localhost.2015-04-09.log (26K) Download Attachment